phpMyAdmin woes - solved

Networking/Security Forums -> UNIX // GNU/Linux

Author: graycatLocation: London, UK PostPosted: Thu Apr 30, 2009 6:09 pm    Post subject: phpMyAdmin woes - solved
greetings all!

In an ever ongoing quest to try other solutions, I'm building an linux based FTP server but have run into a problem gettings phpMyAdmin working.

the system is a CentOS 5 install updated to latest sub-version. I then used
yum install mysql mysql-server phpMyAdmin httpd
to install mysql and phpMyAdmin at the same time. I've configured the databases as needed so far but just can't get phpMyAdmin to display let alone work!

I was getting "403 forbidden" which I resolved by changing /etc/httpd/conf.d/phpMyAdmin.conf to have this:
#  Web application to manage MySQL

<Directory "/usr/share/phpmyadmin">
  #Order Deny,Allow
  #Deny from none
  Allow from all
  Options all
  Options +includes

Alias /phpmyadmin /usr/share/phpmyadmin
Alias /phpMyAdmin /usr/share/phpmyadmin
Alias /mysqladmin /usr/share/phpmyadmin

Adding the Options lines meant that the phpmyadmin file list was then displayed. I think this was because apache wasn't reading index.php as an index file so i added it to the apache config. unfortunately this then meant that the page just gets displayed as text (ie: the source code). Confused

any suggestions or thoughts on where I'm going wrong, guys?

Edit: resolved partially. Seems the initial php install wasn't right. reinstalled that, tweaked the config and it was displaying the page quite happily. well, apart from a blowfish issue now but that's something for tomorrow I think.

Edit 2: cracked the blowfishy problem too - turned out there's a phrase you have to put in by hand in one of the config files. sorted that out and adjusted a permission I had wrong and it let me in.

Job's a good un, you can all relax now Smile

Networking/Security Forums -> UNIX // GNU/Linux

output generated using printer-friendly topic mod, All times are GMT + 2 Hours

Page 1 of 1

Powered by phpBB 2.0.x © 2001 phpBB Group