Upgrade from Exchange 2003 to 2010, have some AD Issues

Networking/Security Forums -> Exchange 2000 // 2003 // 2007 & Active Directory

Author: Thrawn717 PostPosted: Tue Apr 26, 2011 7:07 pm    Post subject: Upgrade from Exchange 2003 to 2010, have some AD Issues
Good Morning,

I just finished doing a upgrade from Exchange 2003 to 2010 and all mailboxes are receiving mail on the new server after everything has been moved over. But I am getting some errors in AD about mail box permissions under the Exchange Advanced Tab. When I click on the mailbox permissions I recieve the follow error.

"The action could not be completed because the Microsoft Exchange Information Store Service is unavailable. Be sure the Service is running and you have network connectivity to the Microsoft Exchange Server computer.
IDno: c1041721
Microsoft Active DIrectory - Exchange Extension"

My guess is that the Exchange Extension is not pointing to the correct server or or something didn't get transferred over correctly. OR there is some permission not allowing the AD to see the new servers Information Store..... All just guesses really and I may be way off.

If any one could point me in the right direction that would be great!


Author: PhiBerLocation: Your MBR PostPosted: Tue Apr 26, 2011 7:11 pm    Post subject:
Try this -
In Active Directory enable seeing advanced options. For the user who has issues, right click on the username, go to security, and check to inherit/propagate permissions.

Let me know if this resolves the issue.


Author: Thrawn717 PostPosted: Tue Apr 26, 2011 7:35 pm    Post subject:
So I opened up Users and Computers, went to View, checked Advanced Features and than right clicked on my account and selected Properties and then went to the Security Tab and than Clicked on the Advanced Button. Under that one I have the Allow Inheritable Permissions from the parent to propagate....... checked already.

Was this what you were talking about?


Author: ryansuttonLocation: San Francisco, California PostPosted: Tue Apr 26, 2011 10:19 pm    Post subject:
I agree that it sounds like an inherited permissions issue. Check the permissions on the Information Store VIA the ESM, make sure they are being inherited. I am surprised you were able to successfully move Mailboxes given this error.

You should also run the BPA and see what it comes up with.

Author: graycatLocation: London, UK PostPosted: Wed Apr 27, 2011 11:57 am    Post subject:
I'm just in the process of migrating from a mix of Exchange 2000 Enterprise and 2003 Standard to Exchange 2010 and have run into similar issues along the way. Every time it has been due to inherited permissions on the AD side of things so I'd start looking there.

Definitely run the BPA but check via PowerShell on the Exchange server(s) as you'll get a lot more info than via the GUI.

Author: Thrawn717 PostPosted: Wed Apr 27, 2011 7:30 pm    Post subject:
Ended up just calling Microsoft and it looked like the Domain Prep command didn't take full effect when it was ran the first time so we had to run it again. Because of that not all of the permissions for mailboxes transffered over for users when we moved mailboxes over.

The main Error I recieved was because of the way I was trying to access Mailbox rights thru the 2003 AD Users & Computers, Exchange Advanced Tab, Mailbox rights. To access those in 2010 you have to go thru Exchange to make changes to those by right clicking on the mailbox and choose Manage Full access permissions or it can be done in the EMS. If you try and access those rights thru AD Users and Computers you will receive the errors that I was getting in a Windows 2003 environment, which that option is not avilable in 2008 AD User and Computers.

So over all MS said everything looked good and everything was configured exactly how it should be and we should be good to go! I was very happy to hear about that! It pays to do research that's for sure and I researched and planned this upgrade out for over 3 to 4 weeks!!

Thanks for all the advice guys!

Author: ryansuttonLocation: San Francisco, California PostPosted: Wed Apr 27, 2011 8:04 pm    Post subject:
Glad you got it sorted out!

Networking/Security Forums -> Exchange 2000 // 2003 // 2007 & Active Directory

output generated using printer-friendly topic mod, All times are GMT + 2 Hours

Page 1 of 1

Powered by phpBB 2.0.x © 2001 phpBB Group