[FAQ] IBM ThinkPad Unlock Supervisor Password
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next  :||:
Networking/Security Forums -> Hardware // Upgrades

Author: allserviceLocation: @your.service PostPosted: Wed Jul 12, 2006 9:38 am    Post subject:
For better results, yes. But give it a try, you never know..

Edit: Yes, that is the chip. Nice shot.

Last edited by allservice on Wed Jul 12, 2006 9:45 am; edited 1 time in total

Author: hadakajime PostPosted: Wed Jul 12, 2006 9:41 am    Post subject:
what program do i use to write the dump? ponyprog?

Author: allserviceLocation: @your.service PostPosted: Wed Jul 12, 2006 9:51 am    Post subject:
You can use whatever you want but the diagram I published there works with PonyProg, which is a classic.

Look out, there are two kind of 93c46, for this one you must select "Microwire 16 bit", In rest they are really easy to program.

Author: hadakajime PostPosted: Fri Jul 14, 2006 1:30 pm    Post subject:
ok i cannot get the circuit to work Evil or Very Mad wen i use ponyprog it keeps showing up only 0's and all the tests fail. i reali tried not to heat the chip too much, and im sure i got the circuit right and there are no shorts. plus i didnt overheat any resistors or diodes because i used a screw board instead of a breadboard

in my view there are only 4 possibilities:

1 - i am not using ponyprog properly

2 - i did overheat the chip with the soldering iron - is there any way i can just buy another one?

3 - i am not grounding it properly - what would you suggest is the best grounding for an unsoldered chip?

4 - it is evil and i should throw it out the window with a stick of TNT attached. afterwards i will smash the remainders on the ground continuously, until i feel it has been unlocked (ie. svp has been removed)

what if i try to use the laptop without the eeprom in it? Very Happy Very Happy Very Happy maybe it will take pity on me and work

Author: allserviceLocation: @your.service PostPosted: Fri Jul 14, 2006 7:23 pm    Post subject:
1. Did you calibrate Pony first?
Don't tell me, you tried to read it soldered, n'est pas?

2. You'll be amazed to know how tough are these little ones. If you didn't brake it in pieces then the chip is good.

3. Ground the COM #5 pin to eeprom GND, and anodes. the zeners have a strip on the cathode part.

If the eeprom pin #6 (ORG) was on GND (not on Vcc as it should normally be), then you must select Microwire 8 bit. Else, use it as microwire 16 bit (this is normal).

No, you can't use the laptop w/o it, take it easy.

4. Relax, have a cigarette or a soda, free your mind and try again Smile

Author: hadakajime PostPosted: Sat Jul 15, 2006 3:34 pm    Post subject:
excellent. your reply fills me with lots of hope. if they are hardy chips then hopefully its probably not overheated from the soldering iron.

yes i calibrated pony. should i select si prog I/O ?
i unsoldered the chip then tried to read it.
now i dont think i had it grounded properly. i will try a different way.

i hav org connected with vcc. how do i change between microwire 8/16bit in ponyprog?

Author: allserviceLocation: @your.service PostPosted: Sun Jul 16, 2006 1:08 am    Post subject:
how do i change between microwire 8/16bit in ponyprog?

Hmm, if you asked me this then I must understand that you did not selected the device at all. Select Microwire 16 bit>9346 in the device list.

SI-Prog API should do it fine.

If you need me to fill your hopes more, well, I know a 14 year old teenager that did this at once. You should do it to, trust me Laughing

Good luck!

Author: KingPin PostPosted: Tue Aug 01, 2006 4:52 pm    Post subject: Password asked when power on my TP t41
Password asked when power on my TP t41

- Allservice , thanks for all the infomations you posted here... It helps me so much .... Can you provide me the 'simple schema' interface and wires and power box !!! I am willing to pay you in return . You can PM me at sylvain.chen-at-cgocable.ca ... thnaks for your help


Author: allserviceLocation: @your.service PostPosted: Sat Aug 05, 2006 2:13 am    Post subject:
Hm, strange that the link you provided here leads to a chinese website where some guys are trying to sell my software as theirs. They seem to have no limit in doing this.
IBMpass 2.0 for example (which btw is a free software) is renamed as "IBMpa", moreover they launched even a new version IBMpa 3.0. Huh?!?

W24RF08 (that version is not genuine) and R24RF08 pictures show ALLservice (this is a miss Laughing ) but they wiped out the author's name, etc.

Anyway, this is an old story....and we are just amusing now.

Author: BADBILLLocation: oKLAHOMA, USA PostPosted: Wed Aug 09, 2006 11:44 pm    Post subject: Ibmpass Shows Blank Password
I have tried several t23 laptops and your fix works great. Very Happy but i have run into a problem the last 5 t23's I've dumped, Ibmpass will not give me a password. i tried ibmpass2.0 but when i go to 0x038 the field is blank (not sure that i am using ibmpass2.0 correctly) am i doing something wrong??? i have my dumps saved so any help would be very help full. thanks for all your help


Author: allserviceLocation: @your.service PostPosted: Sun Aug 13, 2006 12:58 am    Post subject:

If SVP is blank then it is only the POP, just remove the CMOS batt.

Thank you all!

Author: staufj22 PostPosted: Mon Aug 21, 2006 2:53 am    Post subject:
allservice wrote:

If SVP is blank then it is only the POP, just remove the CMOS batt.

Thank you all!

Hi allservice,

Great info you have here. I have a T60, and am trying to remove the POP by removing the backup battery. I was following the instructions in the hardware manual, but its a bit confusing.
It said to first turn off the computer, remove the battery, and then, remove the backup battery, and turn the thing back on.
After the POST, when the POP is wiped, put back both battery.

I was confused as to how to turn the laptop on without either of the 2 batteries.. so I've tried different combinations.. so now, whenever I boot up, it tells me the date-time mismatch, and that security is compromised. In the HMM (ftp://ftp.software.ibm.com/pc/pccbbs/mobiles/39t9448r01.pdf) it said that after I do the POP removal, if there's a SVP, I can still get into the BIOS.. however, thats not the case on my system. Do you think maybe I didn't erase the POP correctly?
I'm guessing that there might be a SVP in addition to the POP..
So.. does your instructions on page 1 of this thread work for T60s?


EDIT - ok, I just finished reading the thread about PC8394T programming tools
. This sounds like a long process...

Author: allserviceLocation: @your.service PostPosted: Mon Aug 21, 2006 8:30 am    Post subject:
When you remove the CMOS battery, POP will be vanished right away. But after that, you have to enter BIOS to set the time/date, otherwise laptop won't boot. This is the usual problem with Thinkpads, SVP is needed anyway (if set)

In rest, your guess is correct, you have the SVP set. PC8394 Tools includes support for T60, and I must say that the procedure is in fact the same like for 24RF08, only the software and the subject (the "dreadful" chip) are different

Author: elwea PostPosted: Wed Aug 23, 2006 10:21 pm    Post subject: T41 problem. Please help me.
I have ThinkPad T41 and forgot password.
If I read the epprom 24RF08CN by simple interface SIPROG to dump file, IBMPASS show "F *" or "Q 29$" (with /A) but this password is wrong. The string in dump file is "21 dl al 92 37 8b 62 f3" in 0x338 to 0x340. Please where is a problem?

Author: allserviceLocation: @your.service PostPosted: Wed Aug 23, 2006 10:44 pm    Post subject:
It is 21d1a1.....
The problem is that the password is encrypted with TCPA chip simply because the passphrase feature is enabled in BIOS setup.
The only way is to reprogram the eeprom.
Other info you can find on the allservice.ro forum, it is all I can say.

Author: elwea PostPosted: Wed Aug 23, 2006 11:05 pm    Post subject: W24RF08 error
if i type w24rf08.exe ibmt41.bin the result if "ERROR: Unable to open source file!". I don't know why. The version is 2.1.

Networking/Security Forums -> Hardware // Upgrades

output generated using printer-friendly topic mod, All times are GMT + 2 Hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next  :||:
Page 6 of 7

Powered by phpBB 2.0.x © 2001 phpBB Group